use strict;
my $str = 'loan balance is $45,56.89
loan balance of $ 1M
Loan Amount of 43000K
loan reimbursement is 54.4 dollars
loan reimbursement is 34,10.45 million
loan balance of 25000$
loan amount $100,200.30
Loan Amount: 100K
Loan Amount $ 1.5 million
loan is $54K
loan balance - 50K$
----------------------------------------------------------------
2.9 millions
$25000.50
1,99$
$25000
1.10 dollar $25000
1,99 dollars $23K
$ 25,00
1.10 dollar $25,000.50
1,99 dollars $25000.50
10 dollar
$ 25,000
1.99$
1,99$
$25000
1.10 dollar $25000.50
1,99 dollars
10 dollar
$ 25,000
25,000.50$
1.99$
$25,000.50
1.10 dollar $25000.50
1,99 dollars $23K
10 dollar $25000
1.99$
$ 25,000
djkb_09$kjh87
gh67_($67.67P)
';
my $regex = qr/\b(?:loan)\s*(?:balance|amounts?|reimbursements?|installments?)?\s*(?:of|is|\s|\:|\-)\s*(?:(?:[\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$)?)|(?:[\.\,\d]+\s*(?:\$)))|(?: [\$]\s*[\.,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?)|(?:[\.\,\d]+\s*(?:millions?|billions?|thousands?|[KMB])?\s*(?:dollars?|\$ ))|(?:[\.\,\d]+\s*(?:\$ ))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}