re = /(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\n?)/
str = '-solutionName $(SolutionName)
-solutionAbbreviation $(SolutionAbbreviation)
-projectName $(ProjectName)
-projectAbbreviation $(ProjectAbbreviation)
-environmentAbbreviation $(EnvironmentAbbreviation)
-appServicePlanAbbreviation $(AppServicePlanAbbreviation)
-logicAppAbbreviation $(LogicAppAbbreviation)
-serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation)
-serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation)
-scanAppServicePlanLocation $(ScanAppServicePlanLocation)
-scanAppServicePlanSKUName $(ScanAppServicePlanSKUName)
-scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier)
-scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers)
-hockeyAppAPIUri $(HockeyAppAPIUri)
-hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant)
-hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience)
-hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId)
-hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret)
-hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval)
-scanQueueNamespaceKind $(ScanQueueNamespaceKind)
-scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName)
-scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier)
-scanQueueNamespaceLocation $(ScanQueueNamespaceLocation)
-scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)
'
subst = '${pair}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result