#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\n?)"
Local $sString = "-solutionName $(SolutionName)" & @CRLF & _
"-solutionAbbreviation $(SolutionAbbreviation)" & @CRLF & _
"-projectName $(ProjectName)" & @CRLF & _
"-projectAbbreviation $(ProjectAbbreviation)" & @CRLF & _
"-environmentAbbreviation $(EnvironmentAbbreviation)" & @CRLF & _
"-appServicePlanAbbreviation $(AppServicePlanAbbreviation)" & @CRLF & _
"-logicAppAbbreviation $(LogicAppAbbreviation)" & @CRLF & _
"-serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation)" & @CRLF & _
"-serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation)" & @CRLF & _
"-scanAppServicePlanLocation $(ScanAppServicePlanLocation)" & @CRLF & _
"-scanAppServicePlanSKUName $(ScanAppServicePlanSKUName)" & @CRLF & _
"-scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier)" & @CRLF & _
"-scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers)" & @CRLF & _
"-hockeyAppAPIUri $(HockeyAppAPIUri)" & @CRLF & _
"-hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant)" & @CRLF & _
"-hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience)" & @CRLF & _
"-hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId)" & @CRLF & _
"-hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret)" & @CRLF & _
"-hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval)" & @CRLF & _
"-scanQueueNamespaceKind $(ScanQueueNamespaceKind)" & @CRLF & _
"-scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName)" & @CRLF & _
"-scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier)" & @CRLF & _
"-scanQueueNamespaceLocation $(ScanQueueNamespaceLocation)" & @CRLF & _
"-scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "${pair}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)