use strict;
my $str = '$this->givenUser1HasPermissionToGroup();$this->andGroupHasPermissionToPortal();$this->andGroupHasPermissionToDevice();$this->andGroupHasPermissionToDataSource1();$this->whenGroupIsDeleted();$this->thenGroupIsntInUser1sPermissions();$this->andGroupIsntInDevicesMemberList();$this->User1HasntPermissionToPortal();$this->andUser1HasntPermissionToDevice();$this->andUser1HasntPermissionToDataSource1();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToPortal();$this->andGroupHasPermissionToPortal();$this->andPortalHasDevice();$this->andPortalHasDataSource1();$this->andDeviceHasDataSource2();$this->whenPortalIsDeleted();$this->thenPortalIsntInUser1sPermissions();$this->andPortalIsntInGroupsPermissions();$this->andDeviceIsntExistent();$this->andDataSource1IsntExistent();$this->andDataSource2IsntExistent();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToDevice();$this->andGroupHasPermissionToDevice();$this->andDeviceHasDataSource2();';
my $regex = qr/(\$this\-\>then.*?;)(\$this\-\>and.*?;){0,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}