#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\$this\-\>then.*?;)(\$this\-\>and.*?;){0,}"
Local $sString = "$this->givenUser1HasPermissionToGroup();$this->andGroupHasPermissionToPortal();$this->andGroupHasPermissionToDevice();$this->andGroupHasPermissionToDataSource1();$this->whenGroupIsDeleted();$this->thenGroupIsntInUser1sPermissions();$this->andGroupIsntInDevicesMemberList();$this->User1HasntPermissionToPortal();$this->andUser1HasntPermissionToDevice();$this->andUser1HasntPermissionToDataSource1();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToPortal();$this->andGroupHasPermissionToPortal();$this->andPortalHasDevice();$this->andPortalHasDataSource1();$this->andDeviceHasDataSource2();$this->whenPortalIsDeleted();$this->thenPortalIsntInUser1sPermissions();$this->andPortalIsntInGroupsPermissions();$this->andDeviceIsntExistent();$this->andDataSource1IsntExistent();$this->andDataSource2IsntExistent();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToDevice();$this->andGroupHasPermissionToDevice();$this->andDeviceHasDataSource2();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")