use strict;
my $str = ' src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);
src: url(".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2");
src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format(\'embedded-opentype\'), url("") format(\'woff\'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format(\'truetype\'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format(\'svg\');
font - style: normal
}
@font - face {
font - family: INGMeBold;
src: url(".. / assets / fonts / INGMeWeb - Bold.eot");
src: url(\'.. / assets / fonts / INGMeWeb - Bold.eot\') format(\'embedded-opentype\'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format(\'woff\'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format(\'truetype\'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format(\'svg\');
font - style: normal';
my $regex = qr/url\(["|']*([^)\?]+\.\w{1,5})(\?[^)"']*)?["|']*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}