#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)url\(["|']*([^)\?]+\.\w{1,5})(\?[^)"']*)?["|']*\)"
Local $sString = " src: url(.. / assets / fonts / INGMeWeb - Regular.eot?v=1.2);" & @CRLF & _
"src: url(".. / assets / fonts / INGMeWeb - Regular.eot?v=1.2");" & @CRLF & _
" src: url(.. / assets / fonts / ING.MeW.eb - Regular.eot?) format('embedded-opentype'), url("") format('woff'), url(.. / assets / fonts / INGMeWeb - Regular.ttf?v=2.3.23&w=23.34) format('truetype'), url(.. / assets / fonts / INGMeWeb - Regular.svg) format('svg');" & @CRLF & _
" font - style: normal" & @CRLF & _
"}" & @CRLF & _
"@font - face {" & @CRLF & _
" font - family: INGMeBold;" & @CRLF & _
" src: url(".. / assets / fonts / INGMeWeb - Bold.eot");" & @CRLF & _
" src: url('.. / assets / fonts / INGMeWeb - Bold.eot') format('embedded-opentype'), url(.. / assets / fonts / INGMeWeb - Bold.woff) format('woff'), url(.. / assets / fonts / INGMeWeb - Bold.ttf) format('truetype'), url(.. / assets / fonts / INGMeWeb - Bold.svg) format('svg');" & @CRLF & _
" font - style: normal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")