$re = '`^(\[\w+\]){1,2}\s(.*?)\s-\s(\d+)?(v\d+)?(\s(\(\w+p\)|(\[\w+p\]))?){1,2}.*$`m';
$str = '[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv
[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv
[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv
[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv
[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);