import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\[\\w+\\]){1,2}\\s(.*?)\\s-\\s(\\d+)?(v\\d+)?(\\s(\\(\\w+p\\)|(\\[\\w+p\\]))?){1,2}.*$";
final String string = "[SubsPlease] Horimiya - 01v2 (1080p) [36C95A42].mkv\n\n\n"
+ "[SubsPlease] Horimiya - 01 (1080p) [36C95A42].mkv\n\n"
+ "[HorribleSubs] 3-gatsu no Lion - 36 [720p].mkv\n\n"
+ "[SubsPlease] Boruto - Naruto Next Generations - 168 (480p) [D05AE2DF].mkv\n\n"
+ "[SubsPlease] Boruto - Naruto Next Generations - 168 [480p] [D05AE2DF].mkv\n\n"
+ "[GHOST][720p] A Certain Scientific Railgun T - 24 [BD HEVC 10bit Dual Audio AC3][C3EBD997].mkv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}