re = /^(?=\w*\d)([a-zA-Z\d+\s()+.-]){10,20}$/
str = '012345678911111111111111111111111111111111111111111111111111111111111111'
# Print the match result
str.match(re) do |match|
puts match.to_s
end