const regex = /^(?=\w*\d)([a-zA-Z\d+\s()+.-]){10,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\w*\\d)([a-zA-Z\\d+\\s()+.-]){10,20}$', '')
const str = `012345678911111111111111111111111111111111111111111111111111111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}