// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(((19|[2-9][0-9])[0-9][0-9])-((0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-8])|((0[13578]|1[02])-(29|30|31))|(0[469]|11)-(29|30)))|((19|[2-9][0-9])(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96)-02-29)$").unwrap();
let string = "1900-03-29";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}