use strict;
my $str = '1900-03-29';
my $regex = qr/^(((19|[2-9][0-9])[0-9][0-9])-((0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-8])|((0[13578]|1[02])-(29|30|31))|(0[469]|11)-(29|30)))|((19|[2-9][0-9])(00|04|08|12|16|20|24|28|32|36|40|44|48|52|56|60|64|68|72|76|80|84|88|92|96)-02-29)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}