$re = '/\{(?:[^{}]|(?R))*\}/x';
$str = '{"id":0,"name":"Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4","size":"682305443"}
{"id":0,"progress":242603704}
{"id":0,"progress":437319904}
{"id":0,"progress":560004744}
{"id":0,"size":682305443,"url":"https://uptobox.com/krafbomfc1qm","deleteUrl":"https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu"}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);