using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{(?:[^{}]|(?R))*\}";
string input = @"{""id"":0,""name"":""Ninja Assassin (2009) [720p] Bluray [filmxy.vip].mp4"",""size"":""682305443""}
{""id"":0,""progress"":242603704}
{""id"":0,""progress"":437319904}
{""id"":0,""progress"":560004744}
{""id"":0,""size"":682305443,""url"":""https://uptobox.com/krafbomfc1qm"",""deleteUrl"":""https://uptobox.com/krafbomfc1qm?killcode=7jgnrwn5fu""}
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}