// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([^\n:#]*)(?::([^\n#]+))?)(?:#([0-9A-Za-z]+)(?:\((\d+\.?\d*)\))?)?").unwrap();
let string = "Phospho#g1
Glycan:Hex
Glycan:Hex#g1(0.10)
#AAA
#AAA(0.10)
Formula:C6H10O5";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}