$re = '/^\d{5}\-\d{5}\-\d{3,12}$/';
$str = '12345-12345-123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);