package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{5}\-\d{5}\-\d{3,12}$`)
var str = `12345-12345-123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}