package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<span.*data-.*="(.+\n.+)`)
var str = `<span data-clipboard-text="advocaciamdc.com
adunsg.com
adogstails.com
AdmissionZilla.com
AcehReseller.com"></span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}