#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<span.*data-.*="(.+\n.+)"
Local $sString = "<span data-clipboard-text="advocaciamdc.com" & @CRLF & _
"adunsg.com" & @CRLF & _
"adogstails.com" & @CRLF & _
"AdmissionZilla.com" & @CRLF & _
"AcehReseller.com"></span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")