# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[A-Za-z](.*)([A-Za-z]|([A-Za-z]{1}[0-9]))(.*?)\s"
test_str = ("c:\\ecpg\\BL_Publish_Staging_CFCS_AP_COA_16\\COA\\fonts\\glyphicons-halflings-regular.woff2 20150616 03:56:18 18028\n\n"
"c:\\\\ecpg\\\\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\\\\images\\\\LOGO.JPG 20130104 06:16:36 4084\n\n"
"c:\\ecpg\\myfolder\\file with space.cfm 20160803 01:09:54 1574\n\n"
"c:\\ecpg\\myfolder\\no_space.cfm 20160803 01:09:54 1574\n\n"
"c:\\ecpg\\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\\add_service.cfm 20160803 01:09:54 1574\n\n"
"c:\\myfolder\\.project 20170221 07:54:10 265\n\n"
"c:\\myfolder asdasdasd ASASASDAS 32423423 sadsd a1234 \\.project123 20170221 07:54:10 265")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.