package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z](.*)([A-Za-z]|([A-Za-z]{1}[0-9]))(.*?)\s`)
var str = `c:\ecpg\BL_Publish_Staging_CFCS_AP_COA_16\COA\fonts\glyphicons-halflings-regular.woff2 20150616 03:56:18 18028
c:\\ecpg\\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\\images\\LOGO.JPG 20130104 06:16:36 4084
c:\ecpg\myfolder\file with space.cfm 20160803 01:09:54 1574
c:\ecpg\myfolder\no_space.cfm 20160803 01:09:54 1574
c:\ecpg\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\add_service.cfm 20160803 01:09:54 1574
c:\myfolder\.project 20170221 07:54:10 265
c:\myfolder asdasdasd ASASASDAS 32423423 sadsd a1234 \.project123 20170221 07:54:10 265`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}