$re = '/^(?:10|[0-9](?:(?:\.|\,)[0-9]?[1-9])?)$/m';
$str = '0
10
0.5
0,25
5,75
3,03
3.03
5.0
5,0
3.333
11
10.5
3.30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);