use strict;
my $str = '0
10
0.5
0,25
5,75
3,03
3.03
5.0
5,0
3.333
11
10.5
3.30';
my $regex = qr/^(?:10|[0-9](?:(?:\.|\,)[0-9]?[1-9])?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}