import Foundation
let pattern = #"((<(.|\n)+?>)?[^=])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<html style='aklfhnakfn'>This is test content
<head font="13"> dummy head </head>
<p> This is a sample?<a href="www.google.com"> a=b=c=d test release </a> </p>
<p> Dummy a = b = c= d </p>
</html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)