use strict;
my $str = '<html style=\'aklfhnakfn\'>This is test content
<head font="13"> dummy head </head>
<p> This is a sample?<a href="www.google.com"> a=b=c=d test release </a> </p>
<p> Dummy a = b = c= d </p>
</html>';
my $regex = qr/((<(.|\n)+?>)?[^=])/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";