package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^(0?[1-9]|[12][0-9]|3[01])\.(0?[1-9]|1[012])\.(19|20)\d\d( ([01]?[0-9]|2[0-3]):[0-5][0-9])?$|^\{ts \'((19|20)\d\d)\-(0?[1-9]|1[012])\-(0?[1-9]|[12][0-9]|3[01]) ([01]?[0-9]|2[0-3]):[0-5][0-9]:[0-5][0-9]\'\}$|^$)`)
var str = `30.12.2013`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}