use strict;
my $str = ' DETECTORES SELECCIONADOS HABILITADOS EVENTO NUMERO 2423 EM 20:38 13-03-15
RELES ISOLADOS EVENTO NUMERO 2496 EM 05:21 23-03-15
EVACUAÇAO EVENTO NUMERO 2497 EM 14:49 23-03-15
ALARME SILENCIADO EVENTO NUMERO 2498 EM 14:49 23-03-15
ENTRADA DE ALTERAÇOES NIVEL ACESSO 02 EVENTO NUMERO 2499 EM 14:49 23-03-15
SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2500 EM 14:49 23-03-15
REPOSIÇAO GERAL REPOSIÇOES 0004 EVENTO NUMERO 2501 EM 14:50 23-03-15
DEFEITO ZONA 023 DSP 094 L03 SIRENE Portaria DISPOSITIVO REMOVIDO EVENTO NUMERO 2502 EM 17:50 24-03-15
FOGO 001 ZONA 011 DSP 033 L01 OPTICO Carrocel, ADM. Setor Qualidade EVENTO NUMERO 2503 EM 03:20 25-03-15
SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2504 EM 03:25 25-03-15
SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2505 EM 03:26 25-03-15
EVACUAÇAO EVENTO NUMERO 2506 EM 03:26 25-03-15
RELES HABILITADOS EVENTO NUMERO 2507 EM 03:26 25-03-15
EVACUAÇAO DESLIGADA EVENTO NUMERO 2508 EM 03:26 25-03-15
';
my $regex = qr/(?=^\s*DETECTORES SELECCIONADOS HABILITADOS).{40}/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}