import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^\\s*DETECTORES SELECCIONADOS HABILITADOS).{40}";
final String string = " DETECTORES SELECCIONADOS HABILITADOS EVENTO NUMERO 2423 EM 20:38 13-03-15 \n"
+ " RELES ISOLADOS EVENTO NUMERO 2496 EM 05:21 23-03-15 \n"
+ " EVACUAÇAO EVENTO NUMERO 2497 EM 14:49 23-03-15 \n"
+ " ALARME SILENCIADO EVENTO NUMERO 2498 EM 14:49 23-03-15 \n"
+ " ENTRADA DE ALTERAÇOES NIVEL ACESSO 02 EVENTO NUMERO 2499 EM 14:49 23-03-15 \n"
+ " SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2500 EM 14:49 23-03-15 \n"
+ " REPOSIÇAO GERAL REPOSIÇOES 0004 EVENTO NUMERO 2501 EM 14:50 23-03-15 \n"
+ "DEFEITO ZONA 023 DSP 094 L03 SIRENE Portaria DISPOSITIVO REMOVIDO EVENTO NUMERO 2502 EM 17:50 24-03-15 \n"
+ "FOGO 001 ZONA 011 DSP 033 L01 OPTICO Carrocel, ADM. Setor Qualidade EVENTO NUMERO 2503 EM 03:20 25-03-15 \n"
+ " SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2504 EM 03:25 25-03-15 \n"
+ " SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2505 EM 03:26 25-03-15 \n"
+ " EVACUAÇAO EVENTO NUMERO 2506 EM 03:26 25-03-15 \n"
+ " RELES HABILITADOS EVENTO NUMERO 2507 EM 03:26 25-03-15 \n"
+ " EVACUAÇAO DESLIGADA EVENTO NUMERO 2508 EM 03:26 25-03-15 \n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}