$re = '/^[a-z0-9._%+-]{1,40}[@]{1}([a-z]{1,20}[.]{1}){1,3}[a-z]{2,8}$/m';
$str = 'serstisal@alumnos.uchceu.es
serstisal@alumnos.uchceu.uchceu.es
serstisal@alumnos.es';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);