#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9._%+-]{1,40}[@]{1}([a-z]{1,20}[.]{1}){1,3}[a-z]{2,8}$"
Local $sString = "serstisal@alumnos.uchceu.es" & @CRLF & _
"" & @CRLF & _
"serstisal@alumnos.uchceu.uchceu.es" & @CRLF & _
"" & @CRLF & _
"serstisal@alumnos.es"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")