$re = '/^\({1,4}[9][\*\-\+\/][9]\)?[\*\-\+\/][9]\){0,2}[\*\-\+\/][9]\){0,1}/';
$str = '(9+9+9+9)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);