package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\({1,4}[9][\*\-\+\/][9]\)?[\*\-\+\/][9]\){0,2}[\*\-\+\/][9]\){0,1}`)
var str = `(9+9+9+9)
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}