import Foundation
let pattern = #"https?:\/\/(?:www\.)?decathlon\.co\.id\/([\w.'_-]+(\/([\w-]+))+?).html"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.decathlon.co.id/in/p/tas-quechua/301684-73330-nh100-10l-country-walking-backpack-black.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}