// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https?:\/\/(?:www\.)?decathlon\.co\.id\/([\w.'_-]+(\/([\w-]+))+?).html").unwrap();
let string = "https://www.decathlon.co.id/in/p/tas-quechua/301684-73330-nh100-10l-country-walking-backpack-black.html";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}