package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\/\*(.*?)\*\/`)
var str = `/**
* Test function \-'-/
*
* @param nothing
*/
function test() {
/* Function */
return; /* End of
the function */
}
/* This works ! */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}