#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\/\*(.*?)\*\/"
Local $sString = "/**" & @CRLF & _
" * Test function \-'-/" & @CRLF & _
" *" & @CRLF & _
" * @param nothing" & @CRLF & _
" */" & @CRLF & _
" function test() {" & @CRLF & _
" /* Function */" & @CRLF & _
" return; /* End of" & @CRLF & _
" the function */" & @CRLF & _
" }" & @CRLF & _
"/* This works ! */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")