$re = '/(^[a-z][a-zA-Z0-9]+)+((_|__)(([a-z][a-zA-Z0-9]+)(_|__)?)+)?$/m';
$str = 'myclasstest
myclassTest
myclassTest_test
myclassTest__test
myclassTest__test_test
myclassTest_test myclassTest__test_test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);