package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[a-z][a-zA-Z0-9]+)+((_|__)(([a-z][a-zA-Z0-9]+)(_|__)?)+)?$`)
var str = `myclasstest
myclassTest
myclassTest_test
myclassTest__test
myclassTest__test_test
myclassTest_test myclassTest__test_test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}