re = /[\p{Sc}\p{So}\p{Mn}\p{P}\p{Z}À-ÿ]/m
str = 'QWERTYUIOPéAsdfghjklHFIUSAF /*-+!"£$%&/()?=^*駰ç_:;[]#@€£█Õ○3═nêj⌂8±£#♫♣èùàò'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end