using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\p{Sc}\p{So}\p{Mn}\p{P}\p{Z}À-ÿ]";
string input = @"QWERTYUIOPéAsdfghjklHFIUSAF /*-+!""£$%&/()?=^*é§ °ç_:;[]#@€£█Õ○3═nêj⌂8±£#♫♣èùàò";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}