$re = '/(?<action>.+)\((?<line_number>\d+)\): Notify: Transaction "(?<transaction_name>.+)" ended with a "(?<transaction_status>.+)" status \(Duration: (?<duration>[\d\.]+) Wasted Time: (?<wasted_time>[\d\.]+)\). \[MsgId: (?<msg_id>.+)\]/';
$str = 'vuser_init.c(48): Notify: Transaction "UC_13_StartPage" ended with a "Pass" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);