import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<action>.+)\\((?<line_number>\\d+)\\): Notify: Transaction \"(?<transaction_name>.+)\" ended with a \"(?<transaction_status>.+)\" status \\(Duration: (?<duration>[\\d\\.]+) Wasted Time: (?<wasted_time>[\\d\\.]+)\\). \\[MsgId: (?<msg_id>.+)\\]";
final String string = "vuser_init.c(48): Notify: Transaction \"UC_13_StartPage\" ended with a \"Pass\" status (Duration: 0.4534 Wasted Time: 0.0002). [MsgId: MMSG-16871]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}