re = /(?<=\d)(?=(\d{3})+(?!\d))/
str = '2244511556654445454454566436'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result