$re = '/(?<=\d)(?=(\d{3})+(?!\d))/';
$str = '2244511556654445454454566436';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;