re = /(Vue\.set\()([\w.\d\n\[\] ]*),([\w.\d\n\[\] ]*),([\w.\d\n\[\] ]*)\);/
str = 'Vue.set(state.items,resourceName, resourceValue);'
# Print the match result
str.match(re) do |match|
puts match.to_s
end