package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Vue\.set\()([\w.\d\n\[\] ]*),([\w.\d\n\[\] ]*),([\w.\d\n\[\] ]*)\);`)
var str = `Vue.set(state.items,resourceName, resourceValue);`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}