import Foundation
let pattern = #"(\d+\.([1-9]{3}|[1-9]{2}|[1-9]|0{1}))(\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#提取有效小数的思路:匹配出符合要求的组合不符合要求的组。
#使用sub函数,re.sub(pat,lambda m:m[1],s)
#repl使用函数,传递的参数是pat,所匹配的match对象,提取match对象中符合要求的组即可。
124.1230000012
124.1200003412
123.0000000012
1.2000
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)