use strict;
my $str = '123.123.123.123:12345
123.0.123.2:23
123.01.123.2:23
123.10.123.2:23
0.1.2.3:1
1.0.2.3:1
223.255.255.255:123
225.255.255.255:123
12.231.21.232:65535';
my $regex = qr/^(?P<IP>(?:[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])(?:\.(?:0|[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])){3}):(?P<PORT>(?:[1-9]|[1-9][0-9]{1,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}