const regex = /^(?P<IP>(?:[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])(?:\.(?:0|[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])){3}):(?P<PORT>(?:[1-9]|[1-9][0-9]{1,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?P<IP>(?:[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-1][0-9]|22[0-3])(?:\\.(?:0|[1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])){3}):(?P<PORT>(?:[1-9]|[1-9][0-9]{1,3}|[1-5][0-9]{4}|6[0-4][0-9]{3}|65[0-4][0-9]{2}|655[0-2][0-9]|6553[0-5]))$', 'gm')
const str = `123.123.123.123:12345
123.0.123.2:23
123.01.123.2:23
123.10.123.2:23
0.1.2.3:1
1.0.2.3:1
223.255.255.255:123
225.255.255.255:123
12.231.21.232:65535`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}